BlogSecurity » 5 Step Failsafe upgrade for WordPress

You can follow this nice little tutorial on how to upgrade to WordPress 2.3 – or you can do it my way, which is fewer steps, but no doubt more dangerous ๐Ÿ™‚


1) Backed up my WordPress folder and database.

2) Uploaded the new WordPress 2.3 files to my server.

3) Clicked on “Upgrade WordPress” when it told me to.

There is no step 4 ๐Ÿ™‚

This is foolish, no doubt, but it worked for me ๐Ÿ™‚


  • For some reason WordPress gave me a message during the upgrade saying, “Are you sure you want to disable the plugin, ”” – even though it didn’t give me the name of the plugin, I told it yes.  Turns out the upgrade disabled Spam Karma2, which I turned back on, and it seems to be working fine.
  • I had disabled the Organize Series plugin because it’s on the list of Plugins that are known to not work with WordPress 2.3.  I’ll wait for an update to the plugin before turning it back on.
  • I removed the BH Category Dropdown Widget because similar functionality is now built into the WordPress Category Widget.
  • Finally, I don’t see a lot different ๐Ÿ™‚


Lets say you’ve got a website running on WordPress 2.2.2 and are about to upgrade to WordPress version 2.3. How can you assure that your WordPress website will run flawlessly after upgrading?

BlogSecurity ร‚ยป 5 Step Failsafe upgrade for WordPress